
EViews Training
Data Objects Basics: Series and Groups 

Note: Data and workfiles for this tutorial are provided in:
 Data: Data.xls 
 Results: Results.wf1
 Practice Workfile: Data.wf1 

Data Series Objects: Series and Groups 

• Series and Groups are the most important Data Objects in Eviews. 

• The actual numeric values of your data are held in the Series Object. 

• A collection of Series (multiple data columns) comprises a Group Object.  

• This tutorial demonstrates basic work with Series and Groups:
 Creating a Series
 Bringing data into EViews
 Creating New Series from Existing Series
 Creating AutoSeries
 Handling Missing Observations 
 Editing, documenting and displaying a Series
 Creating Groups and working with Groups
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Data and Workfile Documentation
• Data.wf1 and Data.xlsx have a number of pages (tabs) with the following 

data: 

• Workfile Page: Timeseries (Data.xlsx tab Timeseries): 
quarterly, Q1 1980 – Q1 2012

 GDP – real GDP data (billions of dollars) from the Bureau of Economic Analysis. 
GDP_revised and GDP_revised1 – real GDP data; slightly changed from original series.  

 PCE – real consumption data (billions of dollars) from the Bureau of Economic Analysis. 
 Inv – real private sector investments (billions of dollars) from the Bureau of Economic Analysis. 
 G – real government spending (billions of dollars) from the Bureau of Economic Analysis. 
 Trend – it’s a trend series, starting with 1 and growing over time. 
Edit_series – a simple series with a few initial values. 
S- a series with only one initial value. 

• Workfile Page: Missing_Example1 (Data.xlsx tab Missing_Example1): 
quarterly, Q1 1980 – Q1 2012

 Inv – real private sector investments (billions of dollars) from the Bureau of Economic Analysis. 
 Missing data coded as “none” 3

Data and Workfile Documentation (cont’d)

• Workfile Page: Missing_Example2 (Data.xlsx tab Missing_Example2): 
quarterly, Q1 1980 – Q1 2012

 Inv – real private sector investments (billions of dollars) from the Bureau of Economic Analysis. 
 Missing data coded as “0” 

• Workfile Page: Missing_Example3 (Data.xlsx tab Missing_Example3): 
quarterly, Q1 1980 – Q1 2012

 Inv – real private sector investments (billions of dollars) from the Bureau of Economic Analysis. 
 Missing data coded as “-999”, “-99”, and “-9”.  

• Workfile Page: Missing_Regression (Data.xlsx tab Missing_Regression): 
quarterly, Q1 1980 – Q1 2012

GDP – real GDP data (billions of dollars) from the Bureau of Economic Analysis. 
 Inv – real private sector investments (billions of dollars) from the Bureau of Economic Analysis. 

 Missing data coded as “NA” 
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Creating a New Series

Creating a New Series: 
Example 1 

Creating a series: Example 1
1. Click on page named Timeseries in 

tutorial4.wf1.
2. Select Object → New Object from 

the main menu.
3. Click the Series option, name it (in 

this case series1).
4. Click OK.
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• There are a number of ways to create a new (empty) series in EViews. 
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• The new series has the 
structure of the workfile 
and NA in all entries.

Creating a New Series: 
Example 1 (cont’d) 

Creating a New Series: 
Example 2 

• Another way to create a series is through the command window. 
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Creating a series : Example 2 
1. On the command window 

type: 
series series2

Note: This instructs EViews to     
create a new series and name it  
newseries. 

2. Press Enter.
3. Locate the new series 

(series2) in the workfile and 
open it.

• The result is the new series 
(series2), which has the 
structure of the workfile and 
NA in all entries.



Creating a New Series: 
Example 3 
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Creating a series: Example 3
1. Click Quick → Empty Group (Edit Series) from the menu toolbar.

• You can also use Quick menu items to create a series. 

Creating a New Series: 
Example 3 (cont’d)

2. A window opens up with a 
blank spreadsheet and 
dates on the side.

3. Scroll up one line (to the 
top of the spreadsheet) and 
type the name of the series 
(series2 here).

4. Click Enter. The “Series 
create” dialog box opens 
up so you can specify the 
type of series.

5. Pick “numeric series” if 
the series you are creating 
will be filled with numeric 
values.

6. Click OK. 
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7. Close the untitled group (EViews
asks if you would like to delete 
Untitled group; click Yes). 

8. Locate “series3” in the workfile and 
open it. 

9. The new series “series3” has the 
structure of the workfile and NA in 
all entries. 

Creating a New Series: 
Example 3 (cont’d)

Bringing Data into EViews



Getting Data into an Existing Workfile: 
Example 1 

• For small data series, you may wish to type in the data (see also Editing 
Series below).  
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Note: This method is not practical when dealing with 
large datasets. 

Typing data in a series:
1. Click on page Timeseries

and open one of the new 
series with empty (NA) 
values we created above. 
For this example, let’s click 
on “series2”.

2. Click the button to 
turn on editing mode (note: 
using Edit +/- depends on 
your option settings; it is 
needed under default 
settings).

3. Start entering in data. 

Getting Data into an Existing Workfile:  
Example 2

Bringing data in EViews by 
Copy/Paste: 
1. Open the data in Excel®

(Note: this also applies to 
other applications). Click on 
tab TimeSeries in the 
Tutorial4_Data.xlsx file. 

2. Highlight the series you wish 
to bring into EViews and select 
Edit → Copy (Note: you do 
not need to copy dates since 
the EViews workfile is already 
structured by date).
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• An easy way to bring data into an existing EViews workfile is by copy/paste

Getting Data into an Existing Workfile:       
Example 2 (cont’d)

3. In EViews workfile click 
Quick → Empty Group 
(Edit Series). 

4. A window opens up with 
a blank spreadsheet and 
dates on the side. Place 
the cursor on the upper-
left cell, right-hand-click, 
and choose Paste. 
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Getting Data into an Existing Workfile: 
Example 3

• Another way to bring data into an existing EViews workfile is by 
importing data from foreign files. 
Importing data into a workfile: 

1. On the menu bar, select File (or Proc) → Import→ Import from file. A standard File 
Open dialog box appears which allows you to locate the file.

2. Click Open once you locate the file. The Excel Read dialog box opens up prompting for 
additional information for the import procedure. 

3. Click Finish to load the data.
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Getting Data into EViews: 
A few notes  

• The easiest way to get data from a single source into Eviews is by using
File → Open → Foreign Data as Workfile (see Tutorial on Creating 
Workfiles for more details). 

• One  main difference between Open Foreign Data as Workfile and Import 
is that the first method brings in the data while at the same time creating a 
new workfile, while Import brings data into an existing workfile.

• If the data comes from various sources (files), it is perhaps best to follow 
these steps to bring data into EViews: 

1. Use File → Open → Foreign Data as Workfile for the more complex or the 
largest files. This also creates a new workfile with a similar structure as the 
source data file. 

2. Use File → Import or Copy/Paste (as shown in the previous two examples) to 
add data from other sources into the main workfile. Please note, that the data in 
all files should have the same structure (i.e., monthly, quarterly, etc.). 
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Creating New Series from Existing 
Series 

Creating a New Series by Transforming an 
Existing series: Example 1 

• You can also create a series by transforming an  existing series. 
• For example, suppose you would like to create a series y=log(gdp). 
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Note: in EViews, log(x) is the natural 
logarithm (not of base 10).

Note: an alternative way to create a 
series is to type genr y= log(gdp)  
in the command window.

Creating a series by transforming an 
existing series: Example 1 

1. Click on the Timeseries page 
on Tutorial4.wf1.  

2. In the command window, type:  
series y = log(gdp)

2. Press the Enter key.

Creating a New Series by Transforming an 
Existing series: Example 2 

• Another way to create a series from an existing series is from the Quick menu:

Creating a series by transforming an existing series: Example 2 
1. On the Timeseries page, click Quick → Generate Series from the menu toolbar. 
2. The window Generate Series by Equation opens. Type your data transformation here (in this 

case, x=log(gdp)). 
3. Click OK. 

• Note that the new series x has the structure of the transformed series.   
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Creating a New Series by Transforming an 
Existing series: Example 3 
• As another example, suppose you would like to create a new series where 

each value is the same as the Q3 2008 value of series “gdp”.
Creating a series by transforming an existing series: Example 3 

1. Click Quick → Generate Series from the menu toolbar. 
2. The window “Generate Series by Equation” opens. Type your data transformation as 

follows:  
z = @elem(gdp,“2008Q3”) 

3. The new series z is equal to the GDP value in Q3 2008.
• Note that series z is equal to the gdp value of Q3 2008. 
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Creating Series Using Samples: 
Example 1

• You can use samples to create a new series from an existing series.
• Suppose you would like to create a series w1= log(gdp) if gdp increases 

compared to the previous period. 
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Note: These commands instructs 
EViews to generate a series w1 = 
log(gdp) when gdp increased 
compared to the previous period. 

Creating a series by using samples: 
Example 1 

1. Click on the Timeseries page, and 
then click Quick → Generate 
Series from the menu toolbar. 

2. The window “Generate Series by 
Equation” opens. On the top 
portion, under “Enter Equation”, 
type the desired transformation:

w1=log(gdp)
3. In the lower portion of the box 

under “Sample”, type the “if” 
sample condition: 

if gdp>gdp(-1) 
Note: gdp(-1) denotes the first lag of gdp

series. For more details on lag 
specification, see tutorial on Data 
Functions.

Creating Series Using Samples: 
Example 1 (cont’d)

• The new series is shown here.

• Note that the new series (w1) has 
the structure of the GDP series. 

• Note also that NAs are propagated 
for those values that do not satisfy 
the “if” condition (i.e., gdp is either 
equal or declined compared to the 
previous period). 
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Creating Series Using Samples: 
Example 1 (cont’d)

• You can replace the missing values (NAs) with zeros (see below for 
more details on handling missing values). 
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To replace NA values with zeros:

1. Create a new series by  typing in the 
command window: 

series w2=@nan(w1,0)

2. Press Enter. 

• Note that @nan(w1,0) instructs EViews to 
create a new series w2 equal to w1 if w1≠NA, 
and 0 otherwise. 

• Note that series w2 (shown here) no longer 
has NA values. They are all replaced by 
zeros. 



Creating Series Using Samples: 
Example 2
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• By modifying the sample, you can also create a new series by splicing a 
number of existing series.

Creating a series by using samples: Example 2
1. Click on the Timeseries page, and then click Quick → Generate Series from the toolbar. 
2. The window “Generate Series by Equation” opens.
3. Type the expressions shown below (you need to repeat steps 1-2 three times since we 

have 3 samples). 

The series splice is defined as follows: 
splice = log(gdp) from Q1 1980 to Q4 1990
splice = log(inv) from Q1 1991 to Q4 2001
splice = log(pce) from Q1 2002 until the end of the workfile range

Creating Series Using Samples: 
Example 2 (cont’d)
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• A graph of the new series 
“splice” is shown here. 

• As you can see, the series 
is constructed according to 
our specifications in all 
three Generate Series by 
Equation dialog boxes 
where we specified the 
samples. 

Creating Series Using Samples: 
Example 2 (cont’d)
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• You can also create the above series by specifying the samples in the command 
window.

Creating a series using samples via the 
command window: 

1. Type in the command window: 
smpl 1980q1 1990q4
series splice_new=log(gdp)
smpl 1991q1 2001q4
series splice_new=log(inv)
smpl 2002q1 @last
series splice_new=log(pce)

2. Note: you need to press Enter 
after every command line above. 
The easiest way to accomplish 
this is to copy/paste each line in 
the command window and hitting 
Enter after every entry. 

Note: Since the sample has changed 
using these commands, you may 
want to revert to the full range by 
typing smpl @all in the command 
window. 

Creating Series Using Samples: 
Example 3 
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• As a last example, consider the following scenario: suppose you have a 
trend series and only the initial value for series s (as shown below). 

• You would like to create a new series by summing up s(-1) with the trend 
series. 

Creating a series by using sample 
commands: Example 3 

1. In the command window, type the 
following: 

smpl @first+1 @last  
s=s(-1)+trend

2. Press the Enter key.

Note: Using @first+1 starts the sample from the 2nd

observation onwards. This is because wehave
the initial value for the series, but want to 
compute the rest. 
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Creating Series Using Samples: 
Example 3 (cont’d) 

• The spreadsheet for the 
complete series s is shown 
here. 

• As seen, the series starts 
at 4.5 (in Q1980) and 
grows over time at the 
same rate as the trend
series. 

Auto Series

Auto-Series
• EViews allows you to work with 

expressions directly, without having to 
create and save a new series.

• Expressions that are used in place of a 
series, are called auto-series.

• To create auto-series simply enter 
expressions anywhere you might use a 
series name.

• The great advantage of auto-series is 
that when the underlying data changes, 
the auto-series will automatically reflect 
these changes.

• The auto-series is deleted from the 
memory when you close the auto-
series window. If you wish to save the 
series, simply click on the        button 
and enter a name. 
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Command “show log(gdp)”
creates an auto-series 
“log(gdp)”

This shows that in place of the series 
name, EViews substitutes the 
expression used to create the series.

Auto-Series in Regressions (cont’d)

• You can use expressions (auto-series) when estimating a regression (for more 
details see tutorial on Estimation). 

• Auto-series can be dependent and/or independent variables.  
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Specifying an equation with Auto Series
1. Click on Timeseries page. Click 

on Quick → Estimate 
Equation. 

2. The Equation Estimation 
dialog box (shown here) opens 
up. Type here your series and 
auto-series, using spaces as 
shown. Note that c stands for 
constant.

3. Click OK.  



Auto-Series in Regressions (cont’d) 

• The estimation output is shown 
here. 

• Note that if an auto-series is the 
dependent variable, EViews will 
forecast the untransformed 
(original) variable and adjust the 
estimated confidence interval.
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Auto-series as Independent variables

Auto-Series in Regressions (cont’d)

• This next example shows the use of auto-series both as dependent and 
independent variables.
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Specifying an equation with Auto Series
1. Click on Timeseries page. Click 

on Quick → Estimate 
Equation. 

2. The Equation Estimation 
dialog box (shown here) opens 
up. Type here your series and 
auto-series, using spaces as 
shown. 

3. Click OK.  

Auto-Series in Regressions (cont’d)
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Auto-series as Dependent and Independent variables

• The estimation output is 
shown here. 

• Note that both dependent 
and independent variables 
are auto-series.

• The auto-series are defined 
as follows: 

• @pcy(gdp) denotes the year-
over-year change in gdp.

• log(inv) denotes the log of inv
series.

• d(pce) denotes the difference 
(from one period to another) in 
pce.  

Missing Values



A Few Notes on Missing Values
• EViews uses the code NA to represent missing data values.
• EViews always excludes observations with NAs from statistical calculations 

(data analysis, regressions, etc.).
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Identifying NA Values to EViews 

• EViews will identify correctly any missing data codes from binary files 
created by other statistical programs.

• When reading data from a foreign source (such as Excel®), EViews will 
automatically convert all non-numeric text into NA when it expects a 
numerical value.

• If missing data is identified by “-999” or “0” (or some other value) in the 
external file, you can instruct EViews to translate these into NA values.

Missing Values: 
Example 1

As a first example, suppose that the missing data in an external file (Excel®
in this case) is coded in a text format as “none” as shown below. 
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Note: In general, if the foreign data source (e.g., excel 
file) has many tabs, you need to click on the 
specific tab from which you wish to load the data in 
EViews. Then you may proceed to load the data. 
This ensures that the data loaded in EViews come 
from this Excel tab, not others.

Missing Values: Example 1
1. Click on the Missing_Example1 EViews page on 

the Tutorial4.wf1 file. 
2. Load the data in EViews by clicking on File → 

Open → Foreign Data as Workfile in the 
EViews toolbar (make sure the 
Missing_Example1 tab is also clicked in the 
Excel file Tutorial4_Data.xls).
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3. The Excel Read dialog box 
opens up; click on Next.

4. Under “Text Representing 
NA” specify the missing 
code; in this case “none”.

5. Press Finish. 

A Few Notes on Missing Values: 
Example 1 (cont’d)
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Converted 
to NA  
values

• Open the “inv” series and notice 
that EViews has converted the 
missing Excel values with code 
“none”, to NAs.  

• Note: EViews allows only one code 
to be translated this way. For 
multiple codes, see Example 3 
below. 

Missing Values: 
Example 1 (cont’d)



Missing Values: 
Example 2

• Suppose that the missing data in an external file is coded as “0”.  
Missing Values: Example 2

1. Click on the Missing_Example2 EViews page on the Tutorial4.wf1 file. 
2. Load the data in EViews by clicking on File → Open → Foreign Data as Workfile in the 

EViews toolbar (make sure the Missing_Example2 tab is also clicked in the excel file 
Tutorial4_Data.xls).

3. The Excel Read dialog box opens up; click on Next. Under “Text Representing NA” specify 
the missing code; in this case “0”. 

4. Press Finish. 
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Converted 
to NA  
values

Missing Values: 
Example 2 (cont’d)

• Open the “inv” series and notice 
that EViews has converted the 
missing Excel values with code “0”, 
to NAs.  

• Note: EViews allows only one code 
to be translated this way. For 
multiple codes, see Example 3 
below. 

Missing Values: 
Example 3
• As a final example, suppose that the missing data in an external file is coded 

as “-9”, “-99” and “-999”. 
Missing Values: Example 3
1. Click on the Missing_Example3 EViews page on the Tutorial4.wf1 file. 
2. Load the data in EViews by clicking on File → Open → Foreign Data as Workfile in the EViews

toolbar (make sure the Missing_Example3 tab is also clicked in the excel file Tutorial4_Data.xls).
3. The Excel Read box opens; click Finish to load the data, ignoring missing values for now. 
4. Click on Quick → Generate Series by Equation. 
5. The Generate Series by Equation box opens up. Recode the values as shown below. 
6. Click OK. 
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Note: The command 
specified in the box 
tells EViews to set to 
“NA” all “inv” values if 
these values are -999, 
or -99, or -9. 
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Missing Values: 
Example 3 (cont’d)

Converted to 
NA  values

• Open the “inv” series and notice that 
EViews has converted the missing 
Excel values with code “-999”, “-99” 
or “-9” to NAs.  

• Note: an alternative way to recode 
the data would be to type the 
following in the command window: 

series y =@recode(inv = -9 
or inv = -99 or inv = -999, 
NA,inv)

• This creates a new series y where all 
the missing values are coded as NA. 



A Few Notes on Missing Values: 
Handling NAs 

• Ordinarily, any operations involving an NA value will result in NA.
• For example, comparisons involving NA values, propagate NA values.
• EViews includes a set of special functions that help out in handling NAs.  
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Main Functions for Missing Values

Function Description
@isna(x) takes the value of 1 if X = NA, 0 otherwise.

@nan(x,y) takes the value of X if X≠NA and Y if X=NA.

@nan(x,0) takes the value of X if X≠NA and 0 if X=NA.

series z = (x=y) series is equal to 1 if x = y and 0 otherwise. NAs are propagated (if 
any of the series has missing values).

series z=@eqna(x,y) series is equal to 1 if x = y and 0 otherwise. NAs are not 
propagated (missing values are replaced with 0).

series z=neqna(x,y) series is equal to 1 if x and y are not equal and 0 if they are equal. 
NAs are not propagated (missing values are replaced with 0).

Missing Values and 
Regression Analysis 

• EViews always excludes missing values from regressions (and other 
statistical analysis. 

• Suppose that you would like to run a regression of “inv” on “gdp”, but “inv” 
has missing values. 
 In the Missing_Regression tab of the Tutorial4_Data.xlsx, there are a total of 

129 observations for “gdp” but only 125 for “inv”, since the latter is missing 4 
values as shown below. 
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Missing Values and Regressions
1. Click on the Missing_regression

EViews page on the Tutorial4.wf1 file. 
2. Load the data in EViews by clicking on 

File → Open → Foreign Data as 
Workfile in the EViews toolbar (make 
sure the Missing_regression tab is also 
clicked in the excel file 
Tutorial4_Data.xls). The Excel Read 
box opens; click Finish to load the 
data. 

3. Select Quick → Estimate Equation 
from the main menu. 

Missing Values and 
Regression Analysis (cont’d) 

4. Define the regression in the 
Equation Estimation box that 
opens up. Here we are 
regressing inv on a constant 
(c) and gdp. 

5. Click OK. 
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Missing Values and 
Regression Analysis (cont’d)

• The estimation output is shown here.
• As you can see, EViews has excluded 

the missing values and estimated the 
regression over 125 observations.
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Editing, Documenting, Displaying 
Series

Editing a Series:
Example 1

Editing a series: Example 1 
1. Click on Timeseries

page in Tutorial4.wfi.  
2. Double-click to open the 

edit_series data. 
3. Click the    button on 

the series toolbar to turn 
on editing mode. This 
allows you to type in data, 
change data, etc..
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• It is very easy to edit a series in EViews.  

Editing a Series:
Example 2

Editing a series: Example 2
1. Click on Timeseries page 

in Tutorial4.wfi.  
2. Double-click to open the 

edit_series data. 
3. Highlight the cells you 

would like to edit (as 
shown here). 

4. Type “=4” in the edit 
window at the top of the 
series. 

5. Press Enter. 
• As you can see, the series 

cells are replaced with the 
value we specified. 
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• You an  also change a number of cells and set them equal to a certain value. 
• For example, suppose you would like to set all the cells highlighted in the 

series below (edit_series) equal to 4. 
Original Series Edited Series

Editing a Series:
Example 3

Editing a series: Example 3
1. Follow steps 1-2 shown in 

Example 2. 
2. Highlight the cells you 

would like to edit (as 
shown here). 

3. Type “+=1” in the edit 
window at the top of the 
series. 

4. Press Enter. 
• As you can see, each 

value in the new region is 
equal to the original value 
plus 1, as we specified. 
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• Suppose you now would like add “+1” to all the your existing observations.  

Original Series Edited Series



Editing a Series:
Example 4

Editing a series: Example 4
1. Follow steps 1-2 in Example 2. 
2. Highlight the cells you would like 

to edit (as shown here). Make 
sure you highlight the data 
starting in 1981Q4 (not 1981 Q3) 
since the previous cell (1981Q2) 
does not have data. 

3. Type “+_1” in the edit window at 
the top of the series. 

4. Press Enter. 
• As you can see, each value in 

the new region is equal to the 
previous value plus 1. This is 
done recursively; only the first 
cell uses original data. 
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• Suppose you now would like add “+1” to all the previous observation, 
recursively.  

Original Series Edited Series

Editing a Series in EViews: 
A Few Notes
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• Note that Examples 2, 3 and 4 above were not done recursively. 
• For example, we performed Example 2 on the original data, and Example 3 

on the data that were changed by Example 2. 
• EViews does not remember the “original” state of the data in the 

spreadsheet - once you used an array expression to change the data, that 
change is permanent and all subsequent modifications are made using the 
new data.

Editing a Series in EViews:
A Few Notes (cont’d)

• Operators (i.e., “=+1”, “+_1”) define how the new values are computed. 
• Below, we list the available operators to editing a series
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Operators to Edit/Change Series Values
Operator Description

= Overwrites the existing value with a new value.

+= Adds the new value to the existing value.

-= Subtracts the new value from the existing value.

*= Multiplies the existing value by the new value.

/= Divides the existing value by the new value.

=_ Overwrites the existing value with the previous cell’s value.

+_ Adds the new value to the previous cell’s value.

-_ Subtracts the new value from the previous cell’s value.

*_ Multiplies the previous cell’s value by the new value.

/_ Divides the previous cell’s value by the new value. 

\ Reverses the order of the selected cells. 

Editing a Series:
Example 5

Editing a series: Example 5
1. Double-click to open the edit_series

data on Timeseries page in 
Tutorial4.wfi.  

2. Highlight the cells you would like to 
edit (as shown here). 

3. Type “=10..20” in the edit window at 
the top of the series. This instructs 
EViews that the starting value of the 
series is 10 and the end is 20. 

4. Press Enter. 
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• If you wish, you also could specify only the start and the end points of the 
observations you wish to edit and allow EViews to fill in the rest. 

Original Series



Editing a Series:
Example 5 (cont’d)

• The edited series (together with 
the original series) are shown 
here. 

• As you can see, the range for the 
values of the edited series start 
with 10 and end with 20. The cells 
in between were interpolated 
using simple linear interpolation.  
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Original Series Edited Series

Editing a Series:
Example 6

Editing a series: Example 6
1. Double-click to open the edit_series data 

on Timeseries page in Tutorial4.wfi.  
2. Highlight the cells you would like to edit 

(as shown here). Make sure you highlight 
the data starting in 1981Q4 (not 1981 Q3) 
since the previous cell (1981Q2) does not 
have data. 

3. Type “+_5..14” in the edit window at the 
top of the series. This instructs EViews to 
add the numbers between the range of 5 
and 14 (interpolated) to the previous cell’s 
values. 

4. Press Enter. 
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• You can also use any of the operators (shown in the earlier table) to set the 
start and end range of the interpolation. 

• Suppose for example, that you would like to add the interpolated values 
between 10 and 20 to the previous cell’s values. 

Original Series

Editing a Series:
Example 6 (cont’d)

• The edited series (together with 
the original series) are shown 
here. 

• As seen, the first value 
(associated with 1981 Q3) is the 
same as before (10) since this is 
where our range starts.

• The next value (1981Q4) is equal 
to the previous value (10) plus 5 
(the start of our interpolation 
range; recall the interpolation 
range is 5-14. 

• The next value (1982Q1) is equal 
to the previous value (15) plus the 
interpolated value of 6.28571.  
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Original Series Edited Series

Editing a Series:
Example 7

Editing a series: Example 7
1. Double-click to open the edit_series

data on Timeseries page in 
Tutorial4.wfi.  

2. Highlight the cells you would like to 
edit (as shown here from 1982Q2-
1983Q1). 

3. Type “=..” in the edit window at the 
top of the series. 

4. Press Enter. 
• As you can see, the values have 

changed, replaced with interpolated 
values between 21.28571 and 72.00. 

60

• You do not need to specify start and end values for the range of 
interpolation. 

• If you simply type “..”, EViews will consider the value of the previous/next cell 
(outside the highlighted range) as a start/end points. 

Original Series Edited Series



Editing a Series:
Example 8

Editing a series: Example 8
1. Let’s show an example that compares a linear vs. a log-

linear (multiplicative) interpolation. Double-click to open 
the edit_series data on Timeseries page in 
Tutorial4.wfi.  

2. Highlight the cells you would like to edit (as shown here 
from 1981Q2-1983Q3). 

3. Type “=5..20” in the edit window at the top of the series. 
4. Press Enter. 
5. To create the log-linear interpolated values repeat the 

same steps as above but type instead “=5..20* ”. The 
added “*” instructs EViews to use log-linear 
(multiplicative) interpolation. 
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• So far, we have used a linear interpolation. 
• We can use other types of interpolation (log linear, cubic spline, etc). 

Editing a Series:
Example 8 (cont’d)

• Both series are shown here. 
• Notice that the start and end 

values are equal to 5 and 20 
(as we specified).

• The interpolated values differ: 
in the linear case, the 
interpolated values are equal 
to end-start/(N-1), where N is 
the number of cells (in our 
case 9). So, the change from 
one cell to another is: 

20-5/9-1=1.875. 
• In the log-linear case, the 

increase in the log value is 
constant, equal to: 
(log(20)-log(5))/(9-1)=0.25257
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Linear Interpolation Log-Linear Interpolation

Editing a Series:
Example 9

Editing a series: Example 9
1. Continue to work with the 

edit_series in the Timeseries page. 
As you can see there are a number 
of missing values. 

2. Highlight the range of series –
including the NA values which you 
would like to interpolate (in this 
case the range is from 1980Q1-
1984-Q3). 

3. Type “_” in the edit window at the 
top of the series. 

4. Press Enter. 
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• You can also interpolate missing (NA) values. 
• There are a number of interpolation techniques in EViews; let’s demonstrate 

a couple.
Original Series

Editing a Series:
Example 9 (cont’d)

• The new (edited) series 
(together with the original 
series) are shown here. 

• Notice that by typing “_” we 
simply instructed EViews to 
interpolate all subsequent 
“NA” values with the previous 
available value. 
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Original Series Edited Series 



Editing a Series:
Example 10

Editing a series: Example 10
1. Double-click to open the edit_series

data on Timeseries page in 
Tutorial4.wfi.  Since in Example 9 
we filled in the missing values with 
the previous data, first let’s try to 
get the data back to the original 
state by deleting all the previous 
entries. For this, click each cell in 
the range 1980Q4-1981Q2 and 
1983Q4-1984Q3 and hit Delete. 

2. Highlight the range of series –in 
this case the range is from 
1980Q1-1984-Q3). 

3. Type “~” in the edit window at the 
top of the series. 

4. Press Enter. 
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• Suppose that instead of interpolating NA values with the previous available 
value, you would like to use a cubic spline. 

Original Series

Editing a Series:
Example 10 (cont’d)

• The new (edited) series 
(together with the original 
series) are shown here. 

• Notice that by typing “~” we 
simply instructed EViews to 
interpolate all “NA” values 
using a cubic spline method. 
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Original Series Edited Series 

Editing a Series in EViews:
Interpolating NA values

• Each interpolation technique has its own symbol. 
• Below, we show the interpolation methods supported by EViews. 
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Interpolation of missing (NA) values

Operator Description
_ Repeats previous non-missing values. 

^ Linear Interpolation.

~ Cubic spline interpolation. 

& Catmull-Rom spline interpolation. 

^* Log-linear (multiplicative) interpolation (linear in log of data).

~* Multiplicative cubic spline interpolation (cubic spline on the log data).

&* Multiplicative Catmull-Rom spline interpolation (Catmull-Rom spline on the 
log data). 

Adjust Mode:
Example 

Adjust Mode: Example 
1. Double-click to open the edit_series

data on Timeseries page in 
Tutorial4.wfi.  

2. Click on the             button in the 
series toolbar. EViews will add 
additional columns to the 
spreadsheet view. The first new 
column titled “Unadjusted” contains 
a copy of the series values at the 
moment you entered adjust mode. 
This “Unadjusted” column is fixed 
and does not change if you change 
the data. 

3. Let’s change a few values in the 
series: replace 1981Q3 with 10; 
1983Q1 with 20 and 1984Q1 with 30.  
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• An new feature in EViews 8 is the “Adjust” mode which allows you to 
compare the data in the original series to any changes you may make. 

Original Series in Adjust Mode



Adjust Mode:
Example (cont’d)
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• The result is shown here. 
• You can notice that EViews has 

filled in two new columns “Delta” 
and “Delta%”. 

• “Delta” shows the raw difference 
between the original 
“Unadjusted” series, and the 
current values in the series. 

• “Delta%” shows the percentage 
difference between the original 
“Unadjusted” series and the 
current values in the series. 

Adjust Mode:
Example (cont’d)

Adjust Mode: Example (cont’d) 
1. Type “6” in the “Delta” column in 

cell 1982Q1. 
2. Type “10” in the “Delta%” 

column in cell 1984Q3. 

• The changes are shown here. 
Note that the raw data in the 
“edit_series” has changed 
accordingly. 
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• When in Adjust mode, you can edit any of the cells in the raw series column 
(the left-most column), or in the “Delta” or “Delta%” columns.

• Suppose you  want the value of the raw data for 1982Q1 for to be 6 units 
greater than the original value and the data for 1984Q3 to be 10% larger. 

Adjust Mode: 
A Few Notes
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• Unlike simple editing of a series in which changes are permanent, changes 
in “Adjust” mode can be reversed. 

• When you exit the “Adjust” mode, either by toggling the Adjust +/- button, 
or by closing the series, EViews asks you if you would like to keep the 
changes you made. 

• Note also that any changes made while in Adjust mode are “live”, meaning 
that any operations (statistical analysis, regressions, etc.) performed using 
the series will use the current edited values. 

• However, exiting the “Adjust” mode offers you the chance to revert back to 
the pre-adjusted values. 

• This property of the “Adjust” mode can be very useful since it allows you 
to perform quick “what if” analysis without permanently changing the 
series.

Documenting a Series
EViews allows you to add more information on your data (source, units, 
remarks) using the Label View.
To add documentation to your data: 
1. On the menu toolbar of a series you wish to document select View → Label.
2. The Series View changes to allow you to add remarks and other data documentation.
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Displaying a Series 
• You can resize the width of a 

column, change the way the 
data is displayed, etc., by 
opening the series 
spreadsheet display.

• Clicking on the Default button 
displays a drop-down menu, 
which tells EViews the format 
of the data.

• The Default shows data in 
raw form; you can change the 
way the data is displayed by 
choosing other options from 
the drop-down menu 
(differenced, % change, log, 
etc.).
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Displaying a Series (cont’d)

• You can customize the formatting of a series by clicking the Properties
toolbar of a series spreadsheet. 

• This opens up the Properties dialog box; select the Display tab.

• This menu allows you to change the number of decimals, separate thousands 
with a comma, or display numbers as fractions. 
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Displaying a Series: 
Narrow vs. Wide  

• You can customize the formatting of a series by pressing the          button 
from the series spreadsheet toolbar.
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Q2Q1 Q3• This command arranges the 
data by the frequency of the 
series. In this example, the 
gdp series in the Timeseries
page is quarterly. 

• A quarterly series will display 
4 observations per row, a 
monthly series 12, and so on.  

Q4

Displaying a Series: 
Sample Adjustments  

• You can toggle between the full range of observations and the current sample 
by pressing the button from the series spreadsheet toolbar.

• Suppose you define the sample by typing in command window: 
smpl 1990q1 @last

• You can now toggle between the full range and the newly create sample by pressing 
the           button. 

• The range (full sample) is 1980Q1 - 2012Q1; the sample is from 1990Q1 -2012Q1. 
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Full Sample New Sample



Adding Observations to Existing Workfiles*
If new updates are available for your data you may add them to your existing workfile.
1. Click on Timeseries page and select Proc → Structure/Resize Current Page 

(either from the main menu toolbar or the workfile toolbar). Alternatively you can 
double-click  Range in the upper pane of the workfile window. 

2. The Workfile Structure dialog box opens up which allows you change the range of 
the workfile. Extend the range of the workfile here (in this case to 2012Q4). 

3. Click OK. 

77* For a more detailed discussion on this topic see Advanced Workfiles.

Adding Observations to Existing Workfiles (cont’d)
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3. EViews adds three missing values 
(NA) at the end of each series in the 
workfile.

4. Copy your data from the source file 
(Excel or others).

5. In EViews open the series you want 
to update, click Edit +/- button, select 
the range of NA values you wish to 
update, and right-click Paste.

• The NA values that were added 
originally to the spreadsheet are now 
updated with the latest values. 

Groups

Groups

• Groups help you work with multiple series.
• A Group is a list of series names (and potentially mathematical expressions) 

that provides access to all the data in that list. 
• Once you create a Group Object, you can use the group name in many 

places to refer to all the series contained in that group.

• A few features of groups:

A group is a “live” feed and is NOT a copy of each individual series. This means 
that if the data in one of the series changes, these changes will also be reflected 
in the group containing the series.

 If a series is deleted from a workfile, the series identifier will be maintained. In the 
group spreadsheet the deleted series will contain NA values.

Renaming a series changes the reference in every group containing the series.

80



Creating Groups: 
Example 1

• There are a number of ways to create groups in EViews. 
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Creating groups: Example 1 
1. Click on Timeseries page. Select Object → New Object from the main  menu.
2. The New Object box opens up. Select the Group option. 
3. You can name your group under the section Name for object (in this case, we 

named it group01), then press OK. 
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4. The Series List window appears. 
Enter the series names you wish 
to include in the group (separated 
by spaces).

Creating Groups: 
Example 1 (cont’d)
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• As seen, EViews has added a 
new object (group01) which 
contains the data from the 
series we specified. 

Creating Groups: 
Example 1 (cont’d)

Creating Groups: 
Example 2

Creating groups: Example 2
1. Click on Timeseries page. Select 

Quick → Show from the main 
menu (or Show from the workfile 
menu).

2. The Show window appears. Type 
here the names of the series you 
wish to include in the group (in this 
example, we type log(gdp) 
log(inv))

3. Press OK.
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• You can also create a group in EViews is by using the Quick menu option. 
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• The result is shown here. 
EViews has created a new 
(untitled) group containing the 
data from log(gdp) and 
log(inv). 

• If you would like to save the 
group, click the         button. 

• The Object Name box opens 
up (as shown below). Name 
the group here (in our case 
group_log). 

Creating Groups: 
Example 2 (cont’d)

Creating Groups: 
Example 3

Creating groups: Example 3
1. Click on Timeseries page. 

Highlight the series you 
wish to group together (in 
this case g and pce).

2. Right-click and select: 
Open  →  as Group.
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• Perhaps the easiest way to create groups is to select series directly from 
the workfile. 
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• The result is shown here. 
EViews has created a new 
(untitled) group containing the 
data from g and pce. 

• As before, if you would like to 
save the group, click the         
button. 

• The Object Name box opens 
up. Name the group here (in 
our case group02). 

Creating Groups: 
Example 3 (cont’d)

Creating Groups: 
Example 4

Creating groups: Example 4
1. Click on Timeseries page. 

Type on the command 
window:

group group03 gdp gdp(-1) 
log(inv) pce/gdp

2. Press Enter. 
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• As a last example, consider creating groups in EViews using the command 
window. 
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• The result is shown here. As 
you can notice, EViews has 
created a new group 
(group03) which contains the 
series we specified in the 
command window (gdp, lag 
GDP, log(inv) and PCE/GDP).

• As it must be evindent by 
now, groups may contain 
Series and Auto-series (series 
expressions such as log(inv), 
gdp(-1) and pce/gdp).  

Creating Groups: 
Example 4 (cont’d) Data Comparison Tools in Groups 

Comparing data between series 
in a group: 
1. Click on Timeseries page. 

Click on gdp and gdp_revised
and open these series as a 
group. Name the group 
group04.  

2. Click the              button  
located in the group menu 
toolbar. 
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• A new feature in EViews 8 allows you to easily compare the data between 
the series in your group. 

• Suppose you have two gdp series: gdp and gdp_revised, where the second 
series has more updated data. You would like to compare the two.   
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• The result is shown here. 
• Notice that, similar to the 

Adjust+/- mode explained 
earlier, the Compare+/-
command adds two new 
columns “Delta” and “Delta%”. 

• “Delta” shows the raw 
difference between the “gdp”  
and “gdp_revised” series. 

• “Delta%” shows the 
percentage difference between 
the two series. 

Data Comparison Tools in Groups 
(cont’d)
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• Note that all four columns are fully editable. 
• For example, if you would like to remove any differences between the two 

series, you can accomplish this by typing “0” in the “Delta” column.
• Note that this change will be reflected in the first series (“gdp”) and not the 

second “gdp_revised”).
• In other words, by typing “0” in the “Delta” column, you are effectively setting 

the first series to equal the second series. 

Data Comparison Tools in Groups 
(cont’d)
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• If you change the series display 
from Default to some other 
setting, EViews removes the 
“Delta%” column and introduces 
new columns showing the new 
transformation and a new “Delta” 
column showing the difference 
for that transformation. 

• Here we chose the Log Diff 
view. As you can notice, EViews
has added two new columns 
showing the log difference for 
each series (dlog(gdp) and 
dlog(gdp_revised) and the 
difference between these two 
(the new “Delta” column). 

• Note that, as before, each 
column is also editable here. 

Data Comparison Tools in Groups 
(cont’d)
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• Note that the default 
comparison in EViews is 
done with zero tolerance. 

• This means EViews will pick 
up even the slightest 
differences between the 
series and highlight these.

• If you would like to change 
the default settings for the 
tolerance level, follow these 
simple steps: 

1. Right-hand click 
anywhere on the 
spreadsheet when in 
Compare Mode. 

2. Select Highlighting. 

Data Comparison Tools in Groups 
(cont’d)
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3. The Comparison Highlighting 
box opens up. Under Highlight if 
difference exceeds field, specify 
your own tolerance level. 

4. Click OK. 

Data Comparison Tools in Groups 
(cont’d)

Data Comparison Tools in Groups 
(cont’d)

Comparing data between three 
series in a group: 
1. Click on Timeseries page. 

Click on gdp, gdp_revised , 
and gdp_revised1 and open 
these series as a group. Name 
the group: group05.  

2. Click the              button  
located in the group menu 
toolbar. 
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• Finally, note that you can compare more than two series.  
• Suppose you have three gdp series: gdp, gdp_revised and gdp_revised1. 

You would like to see the differences between them. 
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• The result is shown here. 
• Notice that, unlike the previous 

examples, EViews no longer adds 
the extra columns. 

• It simply highlights the differences 
between each column. 

• Note also that comparisons are 
carried out in pairs. For example, 
EViews first compares column 1 
with column 2 and highlights 
those differences. Then it 
compares column 2 with column 3 
and highlights those differences.  

Data Comparison Tools in Groups 
(cont’d)


